Bill Allombert on Mon, 18 Jan 2016 11:08:59 +0100

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: Move readline interface to libpari

On Thu, Jan 14, 2016 at 10:20:48AM +0100, Jeroen Demeyer wrote:
> New version of patch with extended comment for pari_use_readline()

As a start, could you change the patch so that pari_rl is an argument to
pari_completion* instead of a public global variable ?

(once it is done, then you can rename pari_rl to rl, rl_... to *rl->...
and remove the macros).

completion_word() should be renamed to pari_completion_word()

readline_interface should be renamed to 'struct pari_rl_interface'

Maybe pari_rl_back and current_ep should be part of readline_interface ?

Also it would be nice if you updated examples/minigp.c to make use of 
this interface.

(I suggest you use 'git format-patch' for generating the patch).